• 23/04/2024

Infokand

Informação e conhecimento para alcançar resultados

Dominando Fórmulas e Funções em Planilhas: Diferenças e Principais Utilizações

Anderson Brito

ByAnderson Brito

ago 10, 2023

Ao explorar planilhas, seja no Microsoft Excel, Google Sheets ou qualquer outro software semelhante, é possível deparar-se com duas características predominantes: as fórmulas e as funções. Apesar de semelhantes, esses dois recursos têm diferenças sutis, principalmente no que diz respeito à sua implementação e complexidade.

As fórmulas são equações que realizam operações com os dados de sua planilha. Elas podem ser tão simples quanto adicionar dois números ou tão complexas quanto calcular previsões estatísticas avançadas. Uma fórmula inicia com um sinal de igual (=) seguido por uma sequência que pode conter números, operadores matemáticos ou referências a outras células.

As funções são subtipo de fórmulas que já vêm pré-definidas nos softwares de planilha. Elas têm o objetivo de simplificar as tarefas, realizando cálculos complexos sem a necessidade do usuário desenvolver equações complicadas.

Funções seguem uma estrutura específica, começando sempre com o nome da função seguido por parênteses, dentro dos quais os argumentos ou parâmetros são inseridos. Por exemplo, a função SOMA() no Excel vai somar todos os valores dentro do intervalo especificado. Funções economizam tempo e, na maioria dos casos, melhoram a precisão dos cálculos, já que reduzem a chance de erros que podem ocorrer ao digitar fórmulas longas e complexas.

Agora que um quadro geral foi pintado sobre o que são fórmulas e funções, eis uma lista com as funções mais utilizadas em planilhas, que são altamente valiosas e versáteis para diversas finalidades de análise de dados.

  1. SOMA(): Esta função soma todos os números em um intervalo de células. Exemplo: =SOMA(A1:A10) somará todos os números de A1 a A10.
  2. MÉDIA(): Esta função calcula a média dos números em um intervalo de células. Exemplo: =MÉDIA(B1:B10) calculará a média dos números de B1 a B10.
  3. CONT.NÚM(): Esta função conta o número de células que contêm números em um determinado intervalo. Exemplo: =CONT.NÚM(C1:C10) contará todas as células no intervalo C1 a C10 que contêm números.
  4. CONTAR.VAZIO(): Esta função conta o número de células vazias em um intervalo específico. Exemplo: =CONTAR.VAZIO(D1:D10) contará todas as células vazias de D1 a D10.
  5. CONT.SE(): Esta função conta o número de células em um intervalo que atendem a uma condição específica. Exemplo: =CONT.SE(E1:E10,”>20″) contará todas as células de E1 a E10 que contêm números maiores que 20.
  6. MIN(): Esta função retorna o menor número em um conjunto de valores. Exemplo: =MIN(F1:F10) retornará o menor número de F1 a F10.
  7. MAX(): Esta função retorna o maior número em um conjunto de valores. Exemplo: =MAX(G1:G10) retornará o maior número de G1 a G10.
  8. HOJE(): Esta função retorna a data de hoje. Exemplo: =HOJE() retornará a data atual.
  9. AGORA(): Esta função retorna a data e a hora atuais. Exemplo: =AGORA() retornará a data e a hora atuais.
  10. DIA(): Esta função retorna o dia de uma data. Exemplo: =DIA(H1) retornará o dia da data em H1.
  11. MÊS(): Esta função retorna o mês de uma data. Exemplo: =MÊS(H2) retornará o mês da data em H2.
  12. ANO(): Esta função retorna o ano de uma data. Exemplo: =ANO(H3) retornará o ano da data em H3.
  13. DIATRABALHO(): Esta função retorna o número de dias úteis entre duas datas. Exemplo: =DIATRABALHO(I1,I2) retornará o número de dias úteis entre as datas em I1 e I2.
  14. DIATRABALHOTOTAL(): Semelhante à função DIATRABALHO(), esta função também retorna o número de dias úteis entre duas datas, mas permite que você especifique quais dias da semana são fins de semana. Exemplo: =DIATRABALHOTOTAL(I3,I4,”0000011″) retornará o número de dias úteis entre as datas em I3 e I4, considerando sábado e domingo como fins de semana.
  15. AGORA(): Esta função retorna a data e a hora atuais. Exemplo: =AGORA() retornará a data e a hora atual.
  16. SE(): Esta função retorna um valor se uma condição for verdadeira e outro valor se for falsa. Exemplo: =SE(J1>10, “Maior que 10”, “Menor que 10”) retornará “Maior que 10” se o valor em J1 for maior que 10 e “Menor que 10” se for menos.
  17. SEERRO(): Esta função retorna um valor se a expressão é um erro e outro valor se não for. Exemplo: =SEERRO(K1/K2, “Erro”) retornará “Erro” se a divisão de K1 por K2 resultar em um erro (como uma divisão por zero).
  18. TRUNCAR(): Esta função arredonda um número para baixo até zero. Exemplo: =TRUNCAR(L1) arredondará o número em L1 para baixo até o inteiro mais próximo.
  19. ARRED(): Esta função arredonda um número para um número específico de dígitos. Exemplo: =ARRED(M1, 2) arredondará o número em M1 para dois dígitos decimais.
  20. APROXIMAR.PARA.CIMA(): Esta função arredonda um número para cima, afastando-se de zero. Exemplo: =APROXIMAR.PARA.CIMA(N1) arredondará o número em N1 para cima.
  21. APROXIMAR.PARA.BAIXO(): Esta função arredonda um número para baixo, em direção ao zero. Exemplo: =APROXIMAR.PARA.BAIXO(O1) arredondará o número em O1 para baixo.
  22. PROCV(): Esta função procura por um valor específico na primeira coluna de um intervalo de células, e então retorna um valor na mesma linha de uma coluna que você especificar. Exemplo: =PROCV(P1, A1:Z100, 3, FALSO) procurará o valor em P1 no intervalo de A1 a Z100 e retornará o valor na mesma linha da terceira coluna.
  23. PROCH(): Semelhante à função PROCV, esta função procura por um valor em uma linha específica, em vez de uma coluna, e retorna um valor na mesma coluna de uma linha que você especificar. Exemplo: =PROCH(Q1, A1:Z100, 3, FALSO) procurará o valor em Q1 no intervalo de A1 a Z100 e retornará o valor na mesma coluna da terceira linha.
  24. ÍNDICE(): Esta função retorna o valor de uma célula específica em um intervalo, com base em um índice de linha e coluna relativo. Exemplo: =ÍNDICE(A1:Z100, 5, 3) retornará o valor na quinta linha e na terceira coluna do intervalo de A1 a Z100.
  25. CORRESP(): Esta função retorna a posição relativa de um item em um intervalo que corresponda a um valor especificado em um determinado modo de corresponder. Exemplo: =CORRESP(R1, A1:A100, 0) retornará a posição do valor em R1 no intervalo de A1 a A100.
  26. SOMASE(): Esta função soma os valores em um intervalo que atendem a uma condição específica. Exemplo: =SOMASE(B1:B10, “>20”) somará todos os valores em B1 a B10 que forem maiores que 20.
  27. SOMASES(): Semelhante à função SOMASE(), esta função soma os valores em um intervalo que atendem a várias condições. Exemplo: =SOMASES(B1:B10, A1:A10, “>20”, C1:C10, “<30”) somará todos os valores em B1 a B10 onde o correspondente valor em A1 a A10 é maior que 20 e o valor em C1 a C10 é menor que 30.
  28. MÉDIASE(): Esta função retorna a média de valores em um intervalo que atendem a uma condição específica. Exemplo: =MÉDIASE(B1:B10, “>20”) tirará a média dos valores em B1 a B10 que são maiores que 20.

Dominar fórmulas e funções em planilhas implica poder manipular e analisar dados de maneira eficaz e precisa. Apesar de suas complexidades inerentes, a familiaridade com estas ferramentas poderosas pode tornar qualquer tarefa relacionada a dados amplamente simplificada e eficiente.

Anderson Brito

By Anderson Brito

Engenheiro de Software com Mestrado que atua na área de TI a quase três décadas. Entusiasta de hardware e conceitos relacionados a IA, Internet das Coisas e Arquitetura de software.

Deixe um comentário

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *